All Activity

This stream auto-updates     

  1. Today
  2. Gabriel Torres

    Menu Manager

    HI @Kevin Carwile Thank you for this great app. I am having two issues here: 1. Menu Manager. I created the new aliases, but when I try to add them at the Menu Manager, they are replaced with the IPS internal path and won't work. See screenshots below. Advanced Path Aliases: Menu Manager: 2. Redirection to the new URLs I want the old links to be replaced and redirected to the new links, but I am lost on how to accomplish that, as I didn't undestand the "Canonical Change Window" setting. Thank you in advance!
  3. Earlier
  4. Bluto

    Condition: link in post content

    return stripos($content->$content(),'http') !== FALSE; or try $search = 'http'; $search_title = stripos($content->title, $search); $search_content = stripos($content->content(), $search); if ($search_title !== FALSE || $search_content !== FALSE ) { $found = 1; } if (count($found) > 0) { return TRUE; } return FALSE;
  5. danydanay

    Feedback plugin integration

    Thanks, but developer dont anserw
  6. I'm trying to create a rule whose condition is that the post content contains a link. I tried just setting it up to search the content for the string "http", but it never triggers. So then I tried writing a custom PHP script to do what I want, but there is a bug in it that I can't isolate -- I get no error message, the page load just crashes. Can anyone either help me figure out why the first method doesn't work, or figure out what's wrong with this PHP set up as a truth value test, "Value is TRUE"? //<?php return stripos($content->$content,'http') !== FALSE;
  7. alexis

    Feedback plugin integration

    I personally do not think it is easy to do... But I can suggest to write a request to authors of that plugin to integrate it with Kevin's Rules. They have their website here: https://ipb.silvesterwebdesigns.com/
  8. danydanay

    Feedback plugin integration

    Hi, i want to integrate with this plugin: https://invisioncommunity.com/files/file/3366-trader-feedback-system/ I think is not difficult but i dont know how to do it
  9. It'd be nice if we could have a "Rules" file to import for basic points additions for actions (i.e., one for when someone replies to something, creates a topic, etc.). Is this located anywhere? If so, where can I get that?
  10. I know this is from 2016...is this still the case? I'd be really nice if the products from Commerce could be shown in points as their pricing instead of USD.
  11. Kevin Carwile

    Remove Slashes Feature doesn't work correctly

    Thanks for the report. I will look into this.
  12. Hi @Kevin Carwile On the IPS 4.4.4 your addon Advanced Path Aliases 1.1.8 with the feature "Remove IPS4 Core FURL Slashes" enabled doesn't work properly on my board. Anytime I post a comment in a topic with more than 1 page, the page automatically loads by Submitting my reply, which should not happen and was not happen on IPS 4.3.*. Also, when choosing a page on a topic here: the page will open something like this: And once I click on update (F5) the page will redirect to the first page: It is not a correct way of working. The page changing should not remove the slash before word "page" on the address line, and should be like this: I believe, this error triggers the page auto loading on the reply submitting. Please help to check and fix, if it is the addon's issue. Thanks,
  13. It's probably because that field has not yet been populated by the member creation process at the time when the rule is ran (which is immediately after the member object is created.) I'm guessing it is a timing issue. You need your rule to run at the end of the member creation process, but it's actually triggered at the very beginning. To compensate for that, you need to offset your condition evaluation to the end of the process. In order to do that, create a custom action from the Rules ACP which takes a member argument. Then create a rule for that custom action which checks the profile field value and has the appropriate actions if the condition is true. Then what you do is trigger your custom action from the "Member created" event, but you set the action to run at the end of the page load, that way, your custom action rule can evaluate against the member once the member data has been fully populated by the creation process.
  14. I've confirmed that this is indeed a bug within the process of merging members and then deleting one of them. Upload the following patch file to fix: ./applications/collab/extensions/core/MemberSync/ipsMemberSync.php ipsMemberSync.php
  15. Hi Kevin. Unfortunately already tried with that Comparison Type and it fails as well. The debug simply states that the condition didn't meet. So I'm really not sure how to troubleshoot.
  16. Oh, sorry. Yeah, you are right. That should be the correct thing to compare to. Just try lossening your value to check to TRUE like, that way if the value of the profile field is something like an integer value of 1, the truth comparison will still see it as true.
  17. But when I compare against "Member that was created" isn't the content between parenthesis the custom field already? (pre-candidato is the custom field) ... Or should I use [member:field_xx] instead?
  18. Looks like your comparing the "Member that was created", which is a Member object to see if its value is Boolean TRUE. Which an object is not a boolean true value. I'm not sure how the value for that checkbox is represented in the system, but I'm guessing that at a minimum, you want to use the "Value is TRUE or equivalent to TRUE" condition to do a soft evaluation of the value. And the value you want to compare is not the "Member that was created". You want to compare against the value of their custom profile field.
  19. Kevin Carwile

    email composition fields not opening in Rules

    I've seen this issue myself. I believe it has something to do with a javascript race condition that occurs on production sites based on the way that the javascript files are combined together by the IPS production packaging. I've tried to work around it a couple of times but still do not seem to have fully succeeded.
  20. Kevin Carwile

    How to add Collab as Model

    In the collab category settings, you must turn on the setting to "Use Collab Models". Then, when a new collab is created, one of the models you have flagged in the category can be selected to be used as the beginning template, if you have the settings set to "Force Model" and you have only one model flagged, it will be automatically used. When a new collab is created, content will not be copied over, only the content containers (forums, databases, galleries, etc).
  21. liquidfractal

    Feature request: Rules for PMs

    Hello, For a future release, I'd like to be able to configure rules around PMs, e.g., I'd like to send out an email notification to members (or members of group X) if they have unread PMs in their mailbox (or mailbox X) which are X weeks/days old. This is only one example, but it seems to me that PMs are glaringly absent from the Rules parameters and should be built in. If there is a way to specify PMs, I don't see it and quite frankly it should be easily accessible in the listing as it is an important aspect of the core suite. Thanks!
  22. I'm trying to make it when a topic is created in a specific forum that the author auto follows the topic. but i don't see an option for anything related to follow in actions. is this not an option?
  23. Hello there, I'm trying to create a rule that adds a secondary member group to a registered user that toggles ON a yes/no custom profile field: I'm using the Truth value for this custom profile field. But it does not work: Any advise? Already tried "Value is TRUE or equivalent to TRUE (any non-empty string/array, number not 0)" but doesn't work either. Regards.
  24. liquidfractal

    email composition fields not opening in Rules

    Strange...I've never had this problem. But in terms of an update of the original topic: I tried exporting my rules, uninstalling Rules and reinstalling from scratch. Then, I tried creating a simple rule which involved sending an email as an action - still got the missing editor space. Re-imported my rules so I'm back to where I started. Stranger still - my development site doesn't have this problem. It's a slightly different domain name on a completely different account, but both sites are on the same VPS server. My dev site also has all the same apps and plugins installed as well.
  25. Daniel B

    How to add Collab as Model

    Hello there, I wonder how does the "flag as collab model" feature work? Because I have already set one Collab as Model; however all new Collabs under the same category won't copy the model's content structure... Nothing really happens. I wonder if I'm missing something? Regards.
  26. alexis

    email composition fields not opening in Rules

    I had and have this situation too. If I change conditions or actions for a rule many times, the Save button doesn't do anything in this rule. Then, I just click "Enter" when on the Rule name line.
  1. Load more activity