All Activity

This stream auto-updates     

  1. Earlier
  2. Zorro_X

    Enable post approval as a rule action

    thankyou, I'll try on a sandbox !
  3. alexis

    Enable post approval as a rule action

    You may try to realize your needs through access to the database using a PHP action in your rule. As far as I know, once post approval is enabled for a topic, at least two important changes inserted into the database: core_content_meta table and forums_topics table. Into the first table such a line is inserted like this: 53 IPS\forums\Topic 95519 core_ItemModeration {"enabled":true,"member":1} And the line in the forums_topics table with topic ID 95519 has the column TOPIC_META_DATA changed from 0 to 1. Also, there should be some specific logs inserted, saying that a moderator enabled post approval in a certain topic. So, you can start with this. I assume it is possible using this way.
  4. Hi, It sounds more like an evolution regarding new functionnalities of V4.5, but maybe someone may indicate how to patch the automation rules original code to allow create actions on subjects that enables/disables post approval. Z
  5. Zorro_X

    The CSRF protection key did not match

    ok, I've tested again, you were right : it works ! Thankyou (again) !
  6. alexis

    The CSRF protection key did not match

    on my live test board it has been saved: after that error appears, you need to refresh the page.
  7. Zorro_X

    The CSRF protection key did not match

    it does not seem tho have saved the settings..
  8. alexis

    The CSRF protection key did not match

    In spite of this error, the changes have been saved successfully
  9. Zorro_X

    The CSRF protection key did not match

    Hi, Now that I've updated my full community and not playing anymore in a test sandbox, I'm discovering new issues with the rules. I've this error message when trying to set notifications parameters in the ACP (disallow users to modify notification methods by the rules) : Error: Call to undefined method IPS\rules\extensions\core\Notifications\Notification::configurationOptions() (0) #0 /home/account/html/system/Dispatcher/Controller.php(90): IPS\core\modules\admin\membersettings\_notifications->edit() #1 /home/account/html/applications/core/modules/admin/membersettings/notifications.php(38): IPS\Dispatcher\_Controller->execute() #2 /home/account/html/system/Dispatcher/Dispatcher.php(152): IPS\core\modules\admin\membersettings\_notifications->execute() #3 /home/account/html/admin/index.php(14): IPS\_Dispatcher->run() #4 {main} A real update would have been really welcome... any news about Kevin ??
  10. Zorro_X

    The CSRF protection key did not match

    hi @alexis : just to say I've tried and it seems to work ! thank you again !
  11. Zorro_X

    4.5.x compatibility

    You should not wait for it, because it seems there will be no update. The best you can do is take a look a this thread :
  12. sandertjeee

    4.5.x compatibility

    Any update on this? Still waiting for 4.5x
  13. Zorro_X

    The CSRF protection key did not match

    @alexis : thankyou !
  14. alexis

    The CSRF protection key did not match

    You can modify those files directly on your server (just edit the already installed files). On my live test board I did an update through the application page (meaning that first I modified the necessary files in the .tar archive of the Rules application). But on my main board I am going to modify the files on the server, since I got some other small custom modifications on the Rules.
  15. Zorro_X

    The CSRF protection key did not match

    Hi, thankyou very much for that tip. Just a question : it should be done on the module files before installation or on the IPS files once installed ? (of course, mine is already installed, but I wonder if I need to modify and install it again or just modify the already installed thing)
  16. Gabriel Torres

    The CSRF protection key did not match

    @alexis Thanks. It worked like a charm. Just frustrated here because this is a paid app with renewal fees, so IMHO the developer should be able to fix this in a timely fashion... thanks!
  17. alexis

    The CSRF protection key did not match

    Don't worry guys, luckily this current issue is easy to fix! The only thing we need to do, is to add these lines into all php files in the "modules" folder of any Kevin's application, so it will start working again: /** * @brief Has been CSRF-protected */ public static $csrfProtected = TRUE; The lines should be added inside the first "class" section, lets see it on an picture below: On the left side is a new view, after the changes has been made, on the right side - is it was before (originally). This changes has to be made in the files, because it is a new IPS developers' requirement regarding the security. @Bluto @Dan @liquidfractal @pixeldude @xSeq2 @Zayon
  18. Zorro_X

    The CSRF protection key did not match

    Same here, it seems the "problem" appeared since the V4.5.4...
  19. alexis

    The CSRF protection key did not match

    This error appears every time by every of the four main Kevin's applications, when creating any rule, any rule set, any collab, any banks or currency or even a new path alias.
  20. Gabriel Torres

    The CSRF protection key did not match

    Hi @Kevin Carwile With the latest 4.5 series, when clicking to edit rules, I am getting: 2S119/1 The CSRF protection key did not match. This may indicate a plugin or theme is out of date. Please contact technical support for more information. Running IPS 4.5.4 with Rules 1.4.6 Thanks.
  21. Zorro_X

    4.5.x compatibility

    you must be sure of that kind of information before spreading a rumor...
  22. Dan

    4.5.x compatibility

    I heard he passed away from complications associated to the recent covid outbreak
  23. liquidfractal

    4.5.x compatibility

    OK, but again - it's only a matter of time. What happens if/when major functionality is added to Gallery/Downloads/Blogs/Pages? Even if Collabs still works, that functionality isn't going to be supported. Ever. And how long do you want to wait until one day things go wrong (which will eventually happen)? Do you think Collabs will still work with IPS 5? 6? If changes in PHP affect Collabs? Anyway, I'm not trying to tell people what to do - I'm really not. I've expressed my opinion here; I've washed my hands of every one of Kevin's apps and am never coming back. Just want to help put things in perspective as someone who was learned from experience. I'd suggest people who want to stay on start thinking of alternatives, anyway. Good luck!
  24. Zorro_X

    4.5.x compatibility

    Sometimes you just need to test and see what happens, that's why most of us creates sandbox work & test copies, to validate thinks like that... Anyway, it will be interesting to know if we stop paying for the licence will the downloaded and installed module still continue to work ? (like in V4.4.X for example)
  25. liquidfractal

    4.5.x compatibility

    Yes, the problem is that if you move forward assuming that there might be "no need to upgrade" without the dev saying so, you're playing an uninsured lottery with your site content. Waiting to see how long it will be before something goes wrong.
  26. liquidfractal

    4.5.x compatibility

    With respect, I think this is beside the point. Aside from my belief that it would be unrealistic to expect IPS to collaborate wtih any one developer (even with such powerful apps as these), my valid complaint has nothing to do with Kevin's relationship with IPS - it has to do with the failed obligation to his paying customers. There's nothing stopping him from continuing development on these apps and making them available for purchase from this site - which, after all, is dedicated to the very apps we're talking about! However, not only has he chosen not to do so - he has left his customers in the dark. And I get it - priorities change, people get new jobs, etc. - however, I should not have to leave 6 messages across different platforms to be told that there will no longer be any development whatsoever, after the last message he released was that critical compatibility upgrades would be made. If you don't believe me when I tell you what Kevin told me (he said "it just doesn't make sense at this point" or something to that effect), proceed at your own risk. I'm here only to seek help on uninstalling Collabs, which is the only thing that won't go quietly. And I just turned 50 and I'm not a developer and have no time to waste (it's a waste for me) on doing something that isn't my chosen vocation.
  1. Load more activity